セキュリティ系の勉強、その他開発メモとか雑談. GithubはUnity触っていた頃ものがメイン Twitterフォローもよろしくです

Docker You are using pip version 10.0.1, however version 18.1 is available.

//

状況

https://graneed.hatenablog.com/entry/2018/06/14/231740
上のサイトを参考にt-potに新しくWOWHoneypotを追加しようと、イメージのBuild中。下のようなエラーが出た。よく見るエラーだけどわかりづらいエラー。

  Could not find a version that satisfies the requirement install (from versions: )
No matching distribution found for install
You are using pip version 10.0.1, however version 18.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

環境は

16.04.5 LTS (GNU/Linux 4.15.0-39-generic x86_64)

今回

# Install packages 
RUN apk -U upgrade && \
    apk add build-base git libssl1.0 openssl-dev libffi-dev  python-dev py-cffi py-ipaddress py-lxml py-mysqldb py-pip py-pysqlite py-requests py-setuptools && \
    pip install --upgrade pip
RUN    pip install pyOpenSSL==16.2.0


1. 上記のエラーからpipのバージョンを上げるために、 pip install --upgrade pip追記 1. ここと似たエラーが出たため、libffi-devapk add行に追記。  

これでビルドに成功

まとめ

linux内のpip系は全く関係ない。Dockerfile内での記述を変更する。Docker初心者にはわかりにくかった。